summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLudovic Pouzenc <ludovic@pouzenc.fr>2010-11-21 22:23:20 +0000
committerLudovic Pouzenc <ludovic@pouzenc.fr>2010-11-21 22:23:20 +0000
commit99cfc03f7fd762b5c7be8548778bdbb37ca2711a (patch)
tree7bdd6d21934e2242609ad6b69322f4f9d685065d /CMakeLists.txt
parent0ee8598e757d1bfc41bc537c5ea24a59967fb207 (diff)
download2010-netlemmings-99cfc03f7fd762b5c7be8548778bdbb37ca2711a.tar.gz
2010-netlemmings-99cfc03f7fd762b5c7be8548778bdbb37ca2711a.tar.bz2
2010-netlemmings-99cfc03f7fd762b5c7be8548778bdbb37ca2711a.zip
Les tests ne compilent pas tout à fait, mais ça attendra demain
git-svn-id: file:///var/svn/2010-netlemmings/trunk@166 077b3477-7977-48bd-8428-443f22f7bfda
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d0be3b6..c63c945 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,8 +7,17 @@ set (NetLemmings_VERSION_MINOR 1)
set(TEST_BINARIES_PATH src/tests)
+# Include the directory itself as a path to include directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+#set(INCLUDE_DIRECTORIES "${PROJECT_SOURCE_DIR}/include")
+set(INCLUDE_DIRECTORIES src/include)
+# add the binary tree to the search path for include files
+# so that we will find netlem.h and netlem_ds.h
+include_directories("${INCLUDE_DIRECTORIES}" "${PROJECT_BINARY_DIR}")
+
add_definitions(-Wall -Wextra -pedantic -Werror -std=c99 -D_POSIX_SOURCE -g)
add_subdirectory(src)
+add_subdirectory(src/test)
enable_testing()
add_test(testfunc001-lex TEST_BINARIES_PATH/test_lex.sh)