summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLudovic Pouzenc <ludovic@pouzenc.fr>2010-11-21 22:13:17 +0000
committerLudovic Pouzenc <ludovic@pouzenc.fr>2010-11-21 22:13:17 +0000
commit0ee8598e757d1bfc41bc537c5ea24a59967fb207 (patch)
treefdd6a42cd81031acf585365a2975821d347dfa8b /CMakeLists.txt
parent0ff965a42f0ad7ab72829b9941bef0b8c20aea45 (diff)
download2010-netlemmings-0ee8598e757d1bfc41bc537c5ea24a59967fb207.tar.gz
2010-netlemmings-0ee8598e757d1bfc41bc537c5ea24a59967fb207.tar.bz2
2010-netlemmings-0ee8598e757d1bfc41bc537c5ea24a59967fb207.zip
CMakeLists par dossier puis beaucoup de retouches pour que ça compile à nouveau. Début de formalisation des tests fonctionnels.
git-svn-id: file:///var/svn/2010-netlemmings/trunk@165 077b3477-7977-48bd-8428-443f22f7bfda
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d0be3b6
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required (VERSION 2.6)
+project (NetLemmings C)
+
+# The version number.
+set (NetLemmings_VERSION_MAJOR 0)
+set (NetLemmings_VERSION_MINOR 1)
+
+set(TEST_BINARIES_PATH src/tests)
+
+add_definitions(-Wall -Wextra -pedantic -Werror -std=c99 -D_POSIX_SOURCE -g)
+add_subdirectory(src)
+
+enable_testing()
+add_test(testfunc001-lex TEST_BINARIES_PATH/test_lex.sh)