summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Pouzenc <lpouzenc@gmail.com>2013-07-09 02:17:30 +0200
committerLudovic Pouzenc <lpouzenc@gmail.com>2013-07-09 02:17:30 +0200
commitf745b369825958c848a64b99c81daffa089d4ea3 (patch)
tree015960549b2f87bae0c6d115b1a49b0cf41c05c2 /configure.ac
downloadmplemmings-f745b369825958c848a64b99c81daffa089d4ea3.tar.gz
mplemmings-f745b369825958c848a64b99c81daffa089d4ea3.tar.bz2
mplemmings-f745b369825958c848a64b99c81daffa089d4ea3.zip
* Initial import : dummy sources, autotools conf ready
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..9f93d16
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,26 @@
+AC_INIT([mplemmings], [0.01], [lpouzenc@gmail.com],
+ [mplemmings], [http://www.pouzenc.fr/mplemmings])
+AC_PREREQ([2.68]) # Default version in Ubuntu 12.04.
+# May work with earlier autoconf versions but this is untested.
+
+AC_CONFIG_SRCDIR([src/mplemmings.c]) # Check the presence of this file
+AC_CONFIG_AUX_DIR([build-aux])
+AC_CONFIG_HEADERS([mplemmings_config.h]) # Generate config.h (PACKAGE_* macros, VERSION...)
+AC_CONFIG_MACRO_DIR([m4]) # Don't use old-style aclocal.m4
+
+AM_INIT_AUTOMAKE([1.11 subdir-objects -Wall -Werror]) # Default version in Ubuntu 12.04.
+# May work with earlier automake versions but this is untested.
+AC_CONFIG_FILES([Makefile])
+
+# Prerequities list
+AC_PROG_CC
+AM_PROG_CC_C_O # For per target CPPFLAGS (used in Makefile.am)
+#AC_PROG_LEX
+#AC_PROG_YACC
+
+# Depedancies detection
+# This uses "pkg-config --cflags sdl2" mechanics and sets DEPS_CFLAGS and DEPS_LIBS makefile vars
+PKG_CHECK_MODULES([DEPS], [sdl2])
+
+# Files generation
+AC_OUTPUT