summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Pouzenc <lpouzenc@gmail.com>2013-07-09 02:17:30 +0200
committerLudovic Pouzenc <lpouzenc@gmail.com>2013-07-09 02:17:30 +0200
commitf745b369825958c848a64b99c81daffa089d4ea3 (patch)
tree015960549b2f87bae0c6d115b1a49b0cf41c05c2 /Makefile.am
downloadmplemmings-f745b369825958c848a64b99c81daffa089d4ea3.tar.gz
mplemmings-f745b369825958c848a64b99c81daffa089d4ea3.tar.bz2
mplemmings-f745b369825958c848a64b99c81daffa089d4ea3.zip
* Initial import : dummy sources, autotools conf ready
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ff218f2
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,23 @@
+ACLOCAL_AMFLAGS = -I m4 --install
+
+# Target list of programs to be install in bin/ dir
+bin_PROGRAMS = mplemmings mplemmings_ds
+
+# Target list of programs that will not installed anywhere (dev helping tiny programs)
+noinst_PROGRAMS = sbmoose
+
+# Use configure detected necessary cflags and ldflags
+AM_CFLAGS = $(DEPS_CFLAGS)
+LIBS = $(DEPS_LIBS)
+
+# Per target specs
+mplemmings_SOURCES = src/mplemmings.c
+
+mplemmings_ds_SOURCES = src/mplemmings_ds.c
+
+sbmoose_SOURCES = src/sandbox/moose.c
+#sbmoose_CPPFLAGS = -DDEBUG
+
+# Extra files to be shipped in the tarball (make dist)
+EXTRA_DIST = m4/.dont-remove rm-all-generated-files.sh
+