summaryrefslogtreecommitdiff
path: root/mcastseed/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'mcastseed/configure.ac')
-rw-r--r--mcastseed/configure.ac41
1 files changed, 31 insertions, 10 deletions
diff --git a/mcastseed/configure.ac b/mcastseed/configure.ac
index ad1db27..e9e292f 100644
--- a/mcastseed/configure.ac
+++ b/mcastseed/configure.ac
@@ -1,14 +1,14 @@
-dnl Process this file with autoconf to produce a configure script.
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
-AC_INIT(mcastseeder, 0.1)
+AC_PREREQ([2.69])
+AC_INIT(mcastseeder, 0.1, ludovic@pouzenc.fr)
# Args deprecated http://www.gnu.org/software/automake/manual/automake.html#Modernize-AM_005fINIT_005fAUTOMAKE-invocation
AM_INIT_AUTOMAKE #(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE
-
-
AC_CANONICAL_HOST
case $host_os in
darwin*)
@@ -23,8 +23,6 @@ case $host_os in
;;
esac
-
-
if test "$HOST_IS_WINDOWS" = "yes"; then
WSOCKLIB="-lws2_32"
AC_SUBST(WSOCKLIB)
@@ -34,15 +32,38 @@ fi
AM_CONDITIONAL(MINGW, [ test "$HOST_IS_WINDOWS" = "yes" ])
AM_CONDITIONAL(DARWIN, [ test "$HOST_IS_DARWIN" = "yes" ])
+# Checks for programs.
AC_ISC_POSIX
AC_HEADER_STDC
AC_PROG_CPP
AC_PROG_CC
+# Gnulib
+gl_EARLY
AM_PROG_CC_STDC
AM_PROG_CC_C_O
+# Checks for libraries.
+
+# Checks for header files.
+AC_CHECK_HEADERS([OS.h fcntl.h limits.h netdb.h stddef.h stdint.h stdlib.h string.h sys/socket.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_HEADER_STDBOOL
+AC_TYPE_SIZE_T
+AC_TYPE_SSIZE_T
+AC_TYPE_UINT32_T
+AC_TYPE_UINT64_T
+AC_TYPE_UINT8_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_CHECK_FUNCS([alarm memset select socket])
+
+AC_CONFIG_FILES([Makefile
+ lib/Makefile
+ src/Makefile])
+
+# Gnulib
+gl_INIT
-AC_OUTPUT([
-Makefile
-src/Makefile
-])
+AC_OUTPUT