summaryrefslogtreecommitdiff
path: root/draft/mcastseed/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'draft/mcastseed/configure.ac')
-rw-r--r--draft/mcastseed/configure.ac69
1 files changed, 69 insertions, 0 deletions
diff --git a/draft/mcastseed/configure.ac b/draft/mcastseed/configure.ac
new file mode 100644
index 0000000..e9e292f
--- /dev/null
+++ b/draft/mcastseed/configure.ac
@@ -0,0 +1,69 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT(mcastseeder, 0.1, ludovic@pouzenc.fr)
+
+# Args deprecated http://www.gnu.org/software/automake/manual/automake.html#Modernize-AM_005fINIT_005fAUTOMAKE-invocation
+AM_INIT_AUTOMAKE #(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
+AM_CONFIG_HEADER(config.h)
+AM_MAINTAINER_MODE
+
+AC_CANONICAL_HOST
+case $host_os in
+ darwin*)
+ HOST_IS_DARWIN="yes"
+ ;;
+ *mingw32*)
+ HOST_IS_WINDOWS="yes"
+ ;;
+ *)
+ HOST_IS_DARWIN="no"
+ HOST_IS_WINDOWS="no"
+ ;;
+esac
+
+if test "$HOST_IS_WINDOWS" = "yes"; then
+ WSOCKLIB="-lws2_32"
+ AC_SUBST(WSOCKLIB)
+fi
+
+
+AM_CONDITIONAL(MINGW, [ test "$HOST_IS_WINDOWS" = "yes" ])
+AM_CONDITIONAL(DARWIN, [ test "$HOST_IS_DARWIN" = "yes" ])
+
+# Checks for programs.
+AC_ISC_POSIX
+AC_HEADER_STDC
+AC_PROG_CPP
+AC_PROG_CC
+# Gnulib
+gl_EARLY
+AM_PROG_CC_STDC
+AM_PROG_CC_C_O
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_CHECK_HEADERS([OS.h fcntl.h limits.h netdb.h stddef.h stdint.h stdlib.h string.h sys/socket.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_HEADER_STDBOOL
+AC_TYPE_SIZE_T
+AC_TYPE_SSIZE_T
+AC_TYPE_UINT32_T
+AC_TYPE_UINT64_T
+AC_TYPE_UINT8_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_CHECK_FUNCS([alarm memset select socket])
+
+AC_CONFIG_FILES([Makefile
+ lib/Makefile
+ src/Makefile])
+
+# Gnulib
+gl_INIT
+
+AC_OUTPUT