summaryrefslogtreecommitdiff
path: root/jeu-test/aliens-1.0.2/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'jeu-test/aliens-1.0.2/configure.in')
-rw-r--r--jeu-test/aliens-1.0.2/configure.in44
1 files changed, 44 insertions, 0 deletions
diff --git a/jeu-test/aliens-1.0.2/configure.in b/jeu-test/aliens-1.0.2/configure.in
new file mode 100644
index 0000000..12f6f9e
--- /dev/null
+++ b/jeu-test/aliens-1.0.2/configure.in
@@ -0,0 +1,44 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(README)
+
+dnl Setup for automake
+AM_INIT_AUTOMAKE(aliens, 1.0.2)
+
+dnl Check for tools
+
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AC_PROG_INSTALL
+
+dnl Check for SDL
+SDL_VERSION=1.0.1
+AM_PATH_SDL($SDL_VERSION,
+ :,
+ AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!])
+)
+CFLAGS="$CFLAGS $SDL_CFLAGS"
+LIBS="$LIBS $SDL_LIBS"
+
+dnl Check for the mixer and IMGlib libraries
+have_SDLmixer=no
+AC_CHECK_LIB(SDL_mixer, Mix_OpenAudio, have_SDLmixer=yes)
+if test x$have_SDLmixer != xyes; then
+ AC_MSG_ERROR([*** Can't find the SDL_mixer library
+Try: http://www.devolution.com/~slouken/SDL/projects/SDL_mixer/
+])
+fi
+have_SDLimage=no
+AC_CHECK_LIB(SDL_image, IMG_Load_RW, have_SDLimage=yes)
+if test x$have_SDLimage != xyes; then
+ AC_MSG_ERROR([*** Can't find the SDL_image library
+Try: http://www.devolution.com/~slouken/SDL/projects/SDL_image/
+])
+fi
+
+# Play the MOD music file
+CFLAGS="$CFLAGS -DPLAY_MOD"
+
+# Finally create all the generated files
+AC_OUTPUT([
+Makefile
+])