summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d0be3b6..c63c945 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,8 +7,17 @@ set (NetLemmings_VERSION_MINOR 1)
set(TEST_BINARIES_PATH src/tests)
+# Include the directory itself as a path to include directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+#set(INCLUDE_DIRECTORIES "${PROJECT_SOURCE_DIR}/include")
+set(INCLUDE_DIRECTORIES src/include)
+# add the binary tree to the search path for include files
+# so that we will find netlem.h and netlem_ds.h
+include_directories("${INCLUDE_DIRECTORIES}" "${PROJECT_BINARY_DIR}")
+
add_definitions(-Wall -Wextra -pedantic -Werror -std=c99 -D_POSIX_SOURCE -g)
add_subdirectory(src)
+add_subdirectory(src/test)
enable_testing()
add_test(testfunc001-lex TEST_BINARIES_PATH/test_lex.sh)